Installing Dispatcher Phoenix

21 minute read Last updated on August 04, 2022

This page contains instructions on how to install and register the standard application, add-in nodes, and maintenance.

Dispatcher Phoenix has a per machine license, meaning the application is licensed and registered to be used on a specific PC only. For instructions on how to transfer a license to a new computer visit License Transfer.

Before you begin installing the application, please make sure that you have administrative privileges on the PC.

To install Dispatcher Phoenix from a CD/DVD or executable file, do the following:

  1. Insert the CD/DVD into the appropriate drive or double-click on Dispatcher Phoenix icon to start the installation process.

  2. If installing from a CD/DVD, the AutoPlay window will appear. Click on the Run autorun.exe option.

    The Dispatcher Phoenix Installer will appear. The following illustration is an example of the Dispatcher Phoenix Installer:

  3. Select the item that you want to install from the drop-down list (Dispatcher Phoenix, Offload license, or Workstation).

  4. Select the version (64-bit or 32-bit) of the application using the radio buttons provided.

  5. Select the Install Application button.

  6. If the User Account Control window appears, asking for confirmation to have Dispatcher Phoenix make changes to your system, select Yes.

  7. On the Welcome window, select the Next button as shown below:

    The User License Agreement window will now appear.

  8. On the User License Agreement window, read the license agreement; then click on the I accept the agreement radio button to continue with the installation process. Select the Next button when you are done. The Information window will now appear.

  9. On the Information window, you can view release information about the application. Select the Next button to continue. The Select Additional Tasks window will now appear.

  10. On the Select Additional Tasks window, you can specify what kinds of icons you want to add to your desktop or toolbar. Select the Next button when you are done.

    Note: The Show Quick Launch option must be enabled in order for a Quick Launch icon to be created. For many operating systems, the Show Quick Launch option can be found on the Taskbar and Start Menu Properties window (accessed by right-clicking on the Start menu and then choosing Properties).

  11. A Ready to Install window will now appear with a summary of what you have chosen. Once you select the Install button, the Set Up window will begin setting up your system for Dispatcher Phoenix.

  12. If multiple source locations are detected (e.g., CD/DVD, USB drive, Internet, etc.), the Select a package repository window will appear, listing all available source locations for package repositories for you to choose from. See the following illustration for an example of the Select a Package Repository window:

For more information on registering Dispatcher Phoenix, please see the Registration page.

Updating Dispatcher Phoenix Without Internet Access

If you need to install Dispatcher Phoenix at a site that has either no or limited Internet connection, do the following:

  1. Copy the Web repository.

  2. Install updates from that downloaded repository.

    Note: For fresh installs of Dispatcher Phoenix, this process will only work if all of the Dispatcher Phoenix prerequisites (Microsoft .Net Framework 4.8, etc.) are installed.

Copy Web Repository

  1. Open the Add-In Manager.

  2. Select the Options button.

  3. On the Options window, click on the Copy Web Repository button.

  4. The Choose a destination to copy the Web repository window will open. Select some external media (e.g., USB drive) to save the repository in; then click on the Select Folder button.

    Note: Make sure you copy the web repository to the media’s root directory or any first-level directory; otherwise, Add-In Manager will not be able to auto-detect the local repository.
    Installation

  5. The powershell.exe window appears and begins downloading the web repository to the specified location. See the following illustration for an example:

    Installation

Install Updates From Downloaded Repository

To install updates using the repository that you just downloaded to some external media, do the following:

  1. Make sure that the media on which you downloaded the web repository is connected to the system that you are trying to update.

  2. Do one of the following:

    • From Dispatcher Phoenix, do the following:

      1. Choose the Check for Updates option from the Help pull-down menu.

      2. The Select a package repository window will appear.

      3. Select the source location that contains your downloaded repository.

      4. Add-In Manager will launch and begin downloading/installing files from that location.

    • From Add-In Manager, do the following:

      1. Click on the Select Updates From: link on the left-hand side of the window.

      2. Select the source location that contains your downloaded repository.

      3. Select the Install Updates button.

Updating Dispatcher Phoenix from a Network Share

Downloading updates for each license may be time-consuming if a business has multiple licenses of Dispatcher Phoenix. As a solution, Add-In Manager can be configured to install all updates from a network share. To set this up, do the following:

  1. Copy the Web repository.

  2. Copy the downloaded repository to a network share.

  3. Open Add-In Manager.

  4. Select the Options button.

  5. Select the Specify optional local repository Browse button to find and select the packages.xml on the network share that contains the downloaded repository. See the following illustration:

  6. Select the Save button to save your changes and close the Add-In Manager.

Using the Add-In Manager

Dispatcher Phoenix offers an Add-In Manager tool that allows for easy installation of additional optional nodes and updates to existing nodes, as well as un-installation of nodes and packages.

Running as Administrator

To perform any updates, uninstalls, or installs, you must have administrative permissions. However, any user can download updates.

Do one of the following:

  • Select the Run as administrator button on the Add-In Manager. Or,

  • Right-click on the Add-In Manager from the Windows program list and then select Run as administrator from the context menu that appears. With this procedure, the Run as administrator button will not appear on the Add-In Manager.

You will receive a UAC prompt. Click on the Yes button to continue. Administrative permissions will be granted until you close the Add-In Manager.

When Downloading Updates In Background

If Add-In Manager begins by downloading updates in the background, the following window will appear when it is time to install:

In this case, click the Install button to be automatically granted administrative privileges and continue with the installation.

Overview of Add-In Manager

The Add-In Manager is available from your Windows Start menu. Browse through your programs until you find the Add-In Manager subfolder underneath the Konica Minolta folder. Once you click on the Add-In Manager folder, you will see the executable file.

When you first open up the Add-In Manager, all nodes/packages that can be uninstalled are listed. You can also click on various items on the left-hand side of the window to either view and install updates or install new optional nodes.

Notes:

  • Add-In Manager runs in the background when updates are downloaded automatically upon first opening the application. This is the default option for updates and can be modified in the Options window found in the Tools menu of the main application screen.

  • You can minimize the Add-In Manager. You can minimize the Add-In Manager window when downloading, installing, or updating. An icon will appear in your system tray; you can double-click on it to see the progress of the operation.

  • Add-In Manager offers multi-select capabilities. You can multi-select items listed in the Add-In Manager to install or uninstall them all at once.

Uninstall

The Uninstall link on the left-hand side of the Add-In Manager window displays a list of all packages that are currently installed on your system. Each item includes a brief description underneath it. To view more details about a specific package, click on an item in the list. A list of its dependencies will appear on the right-hand side of the window

  • To uninstall a specific component, select the Uninstall button. When you uninstall a component, its dependencies will be uninstalled as well. A confirmation message will appear to make sure that you want to uninstall that package.

  • Before the uninstall operation begins, Add-In Manager will look for any running packages. If there are any issues found, the progress bar will turn red and a message will appear the bottom of the window. The following illustration displays the error that occurs if the Dispatcher Phoenix application is open:

Select Updates From

The Select Updates From link on the left-hand side of the Add-In Manager window displays how many updated packages are currently available to be installed (depending on the specific location that is selected). The package repository locations are dynamically detected. To change the type of locations that are listed in this area (Web + Local Repositories, Local Repositories only, or Web only), use the Options window (from the Tools pull-down).

Select the Install Updates button to begin the installation process. A confirmation message will appear to make sure that you want to install updates. Before the update operation begins, Add-In Manager will look for any running packages. If there are any issues found, the progress bar will turn red and a message will appear the bottom of the window.

To view more details about a specific component, click on an item in the list. A list of its dependencies will appear on the right-hand side of the window.

Select Add-Ins From

The Select Add-Ins From link on the left-hand side of the Add-In Manager window displays the new packages that are currently available to be installed (depending on the specific location that is selected). The package repository locations are dynamically detected. To change the type of locations that are listed in this area (Web + Local Repositories, Local Repositories only, or Web only), use the Options window (from the Tools pull-down).

Select a package (or use the Shift + Click to select multiple packages); then select the Install button to begin the installation process. A confirmation message will appear to make sure that you want to install new packages.

Before the install operation begins, Add-In Manager will look for any running packages. If there are any issues found, the progress bar will turn red and a message will appear the bottom of the window.

To view more details about a specific component, click on an item in the list. A list of its dependencies will appear on the right-hand side of the window.

Note: Before installing new packages, all updates must be installed first.

The following illustration is an example of the “detailed” view of Add-In Manager installing a new node:

License Requirements

If the add-in module has NOT been registered yet, the License Required window will appear, listing the name, package, and version for all the add-ins that you have selected to install or update. For example, in the following illustration, the user has attempted to install the Color Route add-in module without registering it first:

On this window, you can do the following:

  • Select the Close button to close the License Required window and return to the Add-In Manager.

  • Select the License Manager button to launch the License Manager window where you can register the add-in node.

Using The Search Field

When looking for installed, updated, or newly created components, you might want to narrow down the list by using the Search field in the upper right-hand side of the Add-In Manager. When you enter a keyword in the blank field provided, the filtered results of your search will be visible for all three options (Uninstall, Updates, and Available to Install). To remove the filtered results, simply delete the phrase in the field or click on the X to clear the field.

Shortcut: Press the forward slash key to bring immediate focus to the Search field.

Checking Version Information

To view a list of all packages currently installed on your system, along with their version numbers, select Version Info… from the Tools pull-down menu in the Add-In Manager.

The Add-In Manager Report window will open, as in the following illustration:

Do the following:

  • To narrow the list of packages displayed, use the Search field on the upper right hand side of the window. To remove the filtered results, simply delete the phrase in the field or click on the X to clear the field.

Shortcut: Press the forward slash key to bring immediate focus to the Search field.

  • To save the report as a PDF file, select the Save As PDF button. A Windows Save As dialog box will appear, allowing you to save the file (with a default name of AIM Report.pdf) in the appropriate location. Once saved, the PDF will be generated and automatically open.

  • To close the Add-In Manager Report, click the Cancel button.

Note: You can also open this window from the License Manager or About box.

Configuring Add-In Manager Options

To specify package repository preferences, copy the web repository to local media, and configuring the view of the Add-In Manager, select Options… from the Tools pull-down menu in the Add-In Manager.

The Options window resembles the following illustration:

Package Repository Default Preferences

You can choose which package repository locations will be available for you to choose when updating or installing packages by selecting one of the following options from the Select behavior for updates and Add-In option installs options:

  • Display Web and all local repositories – This is the default setting. With this option enabled, Add-In Manager will auto-detect and then list the available package repository locations for you to choose from when multiple repository locations are detected (Web, CD/DVD, USB drive, etc.) If a network share or local drive has been specified, it will be listed also.

    When checking for updates in the application, the user will receive a message with the package repositories listed, as in the following illustration:

    When accessing Add-In Manager directly from the Windows Programs menu, the available package repository locations will be listed on the left-hand side of the window, as in the following illustration:

  • Display local repositories only (CD/DVD, USB drive, etc.) – When this option is enabled, Add-In Manager will automatically attempt to use local media, such as a CD/DVD or USB drive, as the source location for the package repositories to be installed/updated. If multiple local repositories are auto-detected, the user will be prompted to choose one. If a network share or local drive has been specified, it will be listed also.

    When accessing Add-In Manager directly from the Windows Programs menu, only those local source locations that include package repositories will be listed on the left-hand side of the window.

If no local repositories are detected, a warning message will appear.

  • Use Web repository only – When this option is enabled, Add-In Manager will automatically download packages from the Internet (as indicated in the Default Web repository field).

    When accessing Add-In Manager directly from the Windows Programs menu, “Web” will be listed on the left-hand side of the window. before installing

  • You can also specify another local repository (i.e., network share or local drive) to be listed as an available source location for package repositories by adding a path location to the Specify optional local repository field. You can use the Browse button to search for and find the repository.

Downloads

  • To modify the default temporary folder where cached download files are saved, click the Browse button… next to the Download files to: field.

  • By default, downloaded files that were installed or updated will be automatically deleted after install/update has completed. To disable this feature, uncheck the Delete cached downloads after successful install or update box. To clear ALL cached files, click on the Clear Cache button.

  • To automatically install packages after they have been downloaded, check the Automatically install after download complete box.

  • To download the web repository to a local media such as a USB drive, click the Copy Web Repository button.

    Note: With this option, Add-In Manager will only check for and download new or updated packages. For this reason, make sure that the Delete cached downloads after successful install or update option is disabled when cloning web repositories.

Add-In Manager Default View

To configure the appearance of the Add-In Manager, choose one of the following:

  • Compact - The default view shows a progress bar along with a product feature slideshow

  • Detailed - This view displays detailed progress messages along with the progress bar.

Restoring Defaults

At any time, you can switch your settings back to their default settings by clicking on the Restore Defaults button.

Downloading

All updates and new packages are downloaded first before they are installed. Installation can occur either manually or automatically after the download has completed. The following illustration is an example of the Downloading window:

On the Downloading window, you can do the following:

  • Check the Auto install after download complete box to automatically begin installation after the download of files has completed. Once checked, this setting applies to all future download operations.

  • Select the Pause button to suspend the download process at any time. If you pause a download, you can resume it at the same point in the download process at a later time by clicking the Resume button.

Different Views

When downloading, uninstalling, or installing, you have the choice of two views:

  • A progress bar along with a product feature slideshow (default view)

  • A progress bar along with detailed installation messages (displayed once the Show Details box is checked)

Uninstalling the Application

To uninstall the Dispatcher Phoenix application, use the Uninstall a program option from the Windows Control Panel. When you choose to uninstall the application, a confirmation message appears.

Registering Add-In Modules

Dispatcher Phoenix is installed with several powerful features. With Add-In modules, you can expand and enhance the features of the application to fit your unique needs.

You can also purchase additional Dispatcher Phoenix base licenses to increase the number of capture sources for your Dispatcher Phoenix workflows. Once you have purchased an additional Dispatcher Phoenix license, follow the instructions below to register the license and increase your number of available inputs.

Due to the fact that you are adding on to an existing installation of Dispatcher Phoenix, the registration process differs slightly from the processes described above for the main application.

Caution! License files are specific to the corresponding installation, so trying to use a license file from a different machine will not work.

To register an add-in, do the following:

  1. Choose Register Add-In… from the Help menu in Dispatcher Phoenix, or the Tools pull-down in the Add-In Manager. (The Register Add-In… option changes to Register Product… if you are running a Demo version of Dispatcher Phoenix). The License Manager will open with the Register Add-In tab already opened, as in the following illustration:

  2. You can do the following:

    • Register automatically
    • Register manually
  3. Activate the Purchase Code or License File.

    The Congratulations window will appear, listing the add-in module(s) that you have just registered.

  4. Select the OK button to close the message; then select the Close button on the License Manager. A message will appear, alerting you to the fact that an updated license has been detected and that Add-In Manager will be used to install the new package(s) available for your license.

  5. If the User Account Control window appears, asking for confirmation to have Dispatcher Phoenix make changes to your system, select Yes.

  6. If multiple source locations are detected (e.g., CD/DVD, USB drive, Internet, etc.), the Select a package repository window will appear, listing all available source locations for package repositories for you to choose from. If this window appears, you should select the appropriate source.

  7. Add-In Manager will launch and the appropriate package(s) will be downloaded and installed.

Add Ins - Automatic Web Registration

To register automatically, do the following:

  1. Select the Automatic Web Registration and Activation radio button.

  2. In the Purchase Code field, enter the purchase code for the add-in module.

  3. Select the Activate button.

Add Ins - Manual Registration

For manual registration, select the Manual Registration radio button and copy the Unlock Code. Go to the Konica Minolta Solutions Engineering Center (SEC) website at SEC website and register the application. To do this, follow these steps:

  1. Copy the unlock code to the clipboard.

  2. Click on the link on the registration page, which will open your browser and bring you to the SEC website (SEC website).

  3. Select the Register button.

  4. Select the Click here to register your add-in or software maintenance radio button.

  5. Enter the valid purchase code you received at the time of your Add-In purchase.

  6. Enter (or paste) the unlock code from your installation of Dispatcher Phoenix.

    Important! Add-Ins require entry of the UNLOCK CODE for verification. This is a departure from the main application registration process.

  7. Select the Submit button to generate the license file which corresponds to your application. A link to this file will be displayed. Click the link to download your license file.

  8. Return to the Dispatcher Phoenix application, browse to and select the appropriate license file, and click Activate. Do NOT unzip the license file prior to activation.

Note: For additional instructions on how to purchase, download, install and license Konica Minolta SEC Applications, please refer to the “Assistance” section of the SEC website.

Licensing

Dispatcher Phoenix licensing governs what features and abilities the application has from “out of the box” through whichever add-ins you decide to purchase and register to enhance the product.

To view what capabilities are licensed for your specific installation of Dispatcher Phoenix, select License Manager from the Help menu. Base nodes and Add-In nodes will be organized separately. In addition, a status of “Installed” or “Not Installed” will be listed next to each node. If a node is installed but the application needs to be restarted in order for the node to be functional, a status of Installed (Application requires restart) will be listed next to it.

Licensing – Counting Active Inputs

Dispatcher Phoenix is licensed by Active Input. An input is any entry point into a workflow (e.g., Input Folder, MFP User Box, MFP Panel, LPR In, SMTP In, Workstation, Email In, Dropbox In, etc.) and is considered active when the workflow is running or is scheduled to run. This means that activating a scheduled workflow will use a license. Any Active Inputs that are duplicated or disabled do not increase the Active Input count.

Note: The Workstation collection node and the Dispatcher Phoenix Mobile collection node do NOT consume an Active Input when used in running workflows. However, user licenses need to be purchased in order to use these features.

Active inputs are counted across multiple workflows by the following:

Input Node Folder Path Host Name IP Address Print Queue URL
MFP Panel - - -
Dropbox In - - - -
Email In - - -
FTP In - -
HTTP In - - - -
Input Folder - - - -
JDF Converter - - - -
LPR In - - - -
MFP User Box - - -
SMTP In - - -
Web Capture - - -

This means that one device used in multiple workflows is only counted ONCE. Similarly, one device used in multiple Input nodes, such as MFP Panel, MFP User Box, and SMTP In, is only counted ONCE. If multiple Input Folders in multiple workflows are collecting from the same directory, they are only counted ONCE.

Note: The Dispatcher Phoenix Mobile and Workstation collection nodes are not counted as Active Inputs.

For more complex workflows, you can increase the number of inputs by purchasing additional Dispatcher Phoenix licenses. Additional licenses increase the number of available inputs by one per license.

Note: The Demo Version comes with three (3) available active inputs. However, this version cannot license any additional inputs beyond these initial three.

In all of the following examples, ONE active input is counted:

THREE workflows are running on the same device (Total Active Input Count = 1):

FIVE workflows are collecting from the same Input Path (Total Active Input Count = 1):

ONE workflow with THREE different types of Input nodes all using the same device (Total Active Input Count = 1):

ONE workflow using 1 LPR In input node (Total Active Input Count = 1):

Active Input Restrictions

  • MFP Panel - One MFP Panel node per workflow
  • SMTP In - One SMTP In node per workflow. Only one SMTP In workflow can run at a time.
  • LPR In - No restrictions

DP Mobile Licensing

Although every Dispatcher Phoenix package includes a DP Mobile Input node, the appropriate licenses for DP Mobile users must be purchased before DP Mobile is available for use.

Dispatcher Phoenix Mobile is licensed by:

  • Users – You can purchase license packs for 10, 25, 50, 100, 250, 500, and 1000 users.

  • Devices – Each individual user can use up to 3 devices to connect to the Dispatcher Phoenix server.

For example, a DP Mobile 10 User License pack would allow 10 users to use DP Mobile on 3 devices each. See the following illustration for an example:

Mobile Licensing

You can view your DP Mobile licensing information using the Options window accessible through the Tools menu in the main application screen.

Re-Activating a License

In the rare case that a license file changes, whether through a system error or tampering, the original license file may be reapplied in order to restore the application to working condition. When the license file cannot be read or has been tampered with, you will need to fill out the following section of the License Manager:

Update License

To restore the license, you may let Dispatcher Phoenix reactivate itself via the web or you may choose to manually restore the license file.

  • To automatically restore the license file, click on the Automatically download and activate the license file radio button and select the Activate button. Dispatcher Phoenix will go to the SEC site, download the appropriate license file, re-install and re-activate that license.

  • To manually restore the license, click on the Manually select and activate the license file radio button. Use the Browse button to locate and select the original downloaded license file. Once selected, click Activate to re-activate the license.

Login Credentials Required

After registration and licensing, if the default password (conopsd) does not meet your organization’s minimum security requirements for passwords, a Setup-SEC Workflow Services window will appear, requesting a password to be entered (or created) and verified, as in the following illustration:

Login Credentials window

Even if the default password does meet minimum security requirements for your organization’s system, it is recommended that you update the default password.